Problems with M2 M-Key slot and Coral Dual Edge TPU/Intel AX200


I’m looking to use a Coral Dual Edge TPU with an adapter in the M.2 M-Key slot of the x1, but the device isn’t being detected. I’ve also tried another adapter with an Intel AX200 Wi-Fi card, which is also not recognized under Linux. However, a Samsung 980 Pro SSD is detected without any issues. Interestingly, both the TPU and Wi-Fi card are recognized when I place them in the E-Key slot. Additionally, both adapters work flawlessly with the M-Key slots of other computers.

Since both adapters require a PCI Express lane in the slot, and the x1 schematic indicates at least one available lane, I’m wondering if my device is defective. What steps should I take to troubleshoot this issue?

Thank you!

On the bottom of the X1, the M-Key port says PCIeX2, which suggests that PCIe devices should work there… but none of them work for me… Has anyone already managed to operate a PCIe device there?
What about the bios settings? I’ve tried various things, none of which had any effect…
If there is no solution, I will have to switch to the Lattepanda Delta 3.

For more information on using the AX200, see this article.

Hi and thank you for your response.
Sadly this does not address my problem… The AX200 was only an example. If I put the AX200 in the E-Key port it is found and installed without any problem under Ubuntu 22.04.

The M2 M-Key Port should accept PCI Express devices other than NVME SSDs but it does not. Even without proper installed drivers the PCIe devices should show up under linux with lspci -vvv . I tried many different BIOS settings but none worked for me. I want to add an external GPU or TPU to the X1 for ML and for this I need a fully functional PCIe port.

Any tipps or hints to get this working?

I found out that some mini pc manufacturers lock their M2 M-Key ports so that only SSDs will work in them. There the behavior is the same as with the X1: NVME SSDs work with full connectivity, but other devices do not.

Is the X1 also locked and if so, can you provide a BIOS that fully unlocks the port?

Are you linking through like this?

M.2 M key to A+E KEY adapter?

Can you give a link to your purchase?

look at this post

Hi Sascha,
Did you find any solution ? i also have the same issue.
The coral TPU works fine in the wifi m.2 slot but when i install a coral TPU in the m.2 m key slot (for SSD) it is not recognized and it doesn’t appear in the windows device manager after boot

please use the new version bios