YY3568 - Debian 10-wifi-dsi0-sd-20230621-001.img

I successfully downloaded and created an SD Card. It boot but it does not look like Linux Debian but somehow Android. Am I confused or the file is not the correct one? Thanks.

Use the tools in this link to burn

  1. Insert the SD card reader into the computer

  2. Open the tool in the link

  3. Check the SD boot option

  4. Click on the Firmware button to select the sd-card.img image

  5. Click the Create button to start burning the system to the SD card

  6. After burning, insert the SD card into the yy3568 SD card slot, power on and start

I can confirm that this works. But…
Windows is a huge PITA for me. I thought I should just be able to dd the image file to my SD flash card using Linux (this is about a board that runs Linux). Is there a recipe for burning the image file to SD Flash without needing Windows? BTW, the documentation doesn’t actually spell out that the PC mentioned is a Windows PC. Even adding that would have been a helpful bit of information. No idea what Mac users are supposed to do.

1 Like

Currently, there is no software available for burning SD cards under the Mac system, only software available under Windows

I finally got it right!
Here is what has happened to me:

  1. First thought looking to a file with extension “img”, I jumped into etcher to burn the SD, to get an error message saying it is not a correct image;
  2. Then I used DD command in Ubuntu, did not work;
  3. I tried the equivalent in MacOS, did not work;
  4. I have Parallels in my iMacPro and tried with Win32Diskimager and got something that I thought was fine, when I realized the boot ignored the SD Card and the already installed Android came up - that is why I opened this topic…
  5. The problem with Parallels is that it does not work well with the SD native in iMacPro. This is out of our scope here;
  6. Today I decided to use SD Tool v.169, as stressed, modify the config file option 1 to 2 so I could read English :), it could not see the SD Card, then I got an USB SD adapter and the tool finally found the SD as an USB Mass Storage. The first “create” failed. I tried again and it took a long time but succeeded. Remember, I am using Windows11 under Parallels in iMacPro.
    7.OK, now I am in Debian 10 but everything is lime green on my screen. I will change it of course but I barely can read it.
  7. Ready to experiment with YY3568 after this inconvenience.
    Suggestion: YY3568 must have images that etcher can deal with. Should we correct the extension “img” to “iso”?

Can you help us understand why the process needs to be so complicated? In virtually all other systems, the image file is written directly to the bootable media, typically SD flash, and there is no need for a specialized tool. This would make things so much simpler and also more consistent with standard practice that most people are familar with.

Is there any documentation of the format of the image file? How would I go about modifying one or creating a custom version?

Thank you for your suggestion. We will improve in the future

No need to change img to iso