YY3568 - can't run Docker

I’ve tried to run Docker on YY3568 with Debian 10, but it doesn’t work.
I narrowed the problem down to that kernel, which is available to download on your page, is not compiled with the BRIDGE support (CONFIG_BRIDGE=y) directive in the kernel compilation configuration.

To solve this by myself, I tried to compile a new Debian image for the device according to your documentation, but unfortunately, it doesn’t work.
I’ve compiled a new image according to this documentation

But when I try to „burn“ this image to the device via RKDevTool it gives the error “Match device type failed, stop running!”. And I’m not able to solve this on my side.

I found these to be three separate issues:

  1. running Docker
  2. being able to build customized images for the device
  3. CONFIG_BRIDGE directive is unfortunate to be left out from the kernel compilation

Can anybody help me solve this?

Thank you

Same goes for building new image via Docker environment. The documentation isn’t correct, there’s no
YY3568-Debian10.mk file inside the docker container.

Ok, I was “somehow” able to build new image of Debian OS. I’m not sure what made the difference. Maybe running the setenv.sh script.

Could you please recheck the documentation and update it on building the images?

Secondly, I’m running into a one issue after another while trying to run Docker on this device. Would it be possible to solve the dependencies in kernel and so on your side?

After enabling BRIDGE in kernel I’ve run into another problem with iptables:

You can solve that by updating-alternatives to legacy iptables, but that raises another errors. And so on.

Would it be possible to look into it on you developer side?

Thank you for your response.

Try the following command

Can you upload the picture so that we can analyze the problem


I’ve tried this, but it doesn’t resolve the issue.

If you use this and do exactly as is written in the wiki documentation the process doesn’t work.
There’s a wrong link named “.target_product” in device/rockchip/ folder that points (in the Docker environment) to not existing file (the absolute path is wrong). But it works well if you’re not using docker environment for building the image.
I was able to fix that, by setting relative path it points to, instead of absolute path.

But the build process will fail anyway further down the road. I’m attaching the error in pastebin:

This is it:
====Start build rockchip_rk356x_recovery====

2023-06-14T16:42:50 >>> host-tar 1.29 Installing to host directory

Done in 9s (error code: 2)

Command exited with non-zero status 2

you take 0:10.58 to build recovery

ERROR: Running build_recovery failed!

ERROR: exit code 2 from line 879:

/usr/bin/time -f “you take %E to build recovery” $COMMON_DIR/mk-ramdisk.sh recovery.img $RK_CFG_RECOVERY


rm device/lokchip/.target_product

rm -fr buildroot/output

Permission issue, the root in the Docker is not the actual root user.