YY3568 breaks down after two resets

I succesfully installed debian on the YY3568. It ran verry smooth and fast.
Then I tried some tinge. First I had youtube in te browser running including sound. Then it stoped playing the video’s. To start the video’s I had to cancel the sound.
Then when I wanted to restart the YY3568, I hit accidently the reset button twice shortly after each other.
After that moment the yy3568 didn’t want to start any more, even after reinstalling debian.
What should I do now?

Can the device enter loader or maskrom mode?

Check here:

Yes I did first a normal upgrade and then an upgrade in maskrom mode, but without succes

Can you take some photos?I want to know at which step did you experience an abnormality?

In these pictures you see the proces of the loading of the firmware. It looks as of everything went ok.
But when connecting hdmi, network, keyboard, mouse and power, the two blue leds stay on and nothing appears on the monitor.

You can try this method:
1.Enter maskrom mode,select the firmware you want to upgrade,Click Unpack
2.After unpacking, find the bin file in the output of RKTOOL and click Download.
3.Waiting for download to succeed
4.Click EraseAll

After successful erasure, restart and upgrade the firmware again

I did everything as you instructed and it looked like it was a succes, but the board did not start up.
I connected the uart-debug to an other computer and I can see that there is some output, but I can not read it because I do not know the serial port settings. I tries some common setting, but no succes.

See Wiki for how to use the debug UART.


this what I tried first, but did not work out. Apparently I need other settings. parity?, stopbits? databits?


Do you have an SD card?
Try booting via SD card.

I did this: the “SDcard image” link is not working. On an other place I found: YY3568-Debain10-wifi-dsi0-sd-20230621.
I used this image, but without any succes.
Some other strange things: I have to hold the “recovery”-key for at least 10 seconds before RKDevtool says: Found one MASKROM device
The uart-debug gives no output anymore

You may need to apply for the after-sales process, please contact your salesperson with your order information.