X1 Not Displaying

I’ve just received my X1 and cannot get it to show anything on a screen. I’ve got the 8GB RAM, no eMMC version. I have powered it on successfully since the LEDs are lit and the fan is on, but there is no startup logo or anything coming on to my monitor.

I have tried multiple displays through both HDMI and micro-HDMI, and have tried this with a USB bootable, SSD with Windows, and with no disks plugged in but all with the same result.

Is there something I am doing wrong or is there something wrong with the board I received? Please write back with any further questions, since I would be happy to give more information if necessary in order to troubleshoot the X1.

When there is no emmc,no SSD or other boot media, this page is displayed via HDMI.

Please check your display and HDMI cable first.

Hello, so I’ve now tested this with different HDMI cables that I know work for different devices and a monitor that works with all of them. This did not work for me.

What should be my next step to solve this issue? Should I attempt to update the BIOS? Also, is it any indicator that both the red and green LEDs are lit?

Thank you for your help.

next step, install system