Stuck in NVIDIA Logo - Jetson Nano Sub Kit Not Booting after Partition Deletion


I have been facing some issues with my Jetson Nano Developers Kit. Initially, I had a 128GB SD card, but it only showed me around 28GB of storage, spread across two disks - a 16GB eMMC in the carrier board and the rest from my SD card. After using “lsblk,” I found that my 128GB disk had 14 partitions, and only one of them was mounted, which meant I was only getting about 12GB of space from my 128GB disk. To resolve this issue, I decided to delete the partitions and leave only one partition with the remaining 116GB, hoping that it would solve my space problems.

However, when I tried to install a Python library (TensorFlow), I noticed that it was getting installed in the 16GB eMMC instead of the SD card. I tried moving the Python path and setting a TMPDIR, but it still consumed space from the eMMC. I then thought of moving all the contents from the eMMC to the second partition (116GB), hoping to stop my space problems. But when I used rsync to move the contents, the space available in the 16GB eMMC went to 0 bytes, and the space in the second partition did not change. I left it for a while and then faced a power outage.

After plugging in my Jetson Nano Developers Kit, it got stuck on the Nvidia logo and didn’t boot. I tried flashing the SD card image again on my 128GB SD card, but the boot was still not happening, and the screen was frozen. I researched and found tutorials on the Nvidia forum suggesting that I flash the SDK using SDKManger. However, I realized that I had a Youyeetoo Jetson Nano Sub Kit with an SD slot, which is an alternative to Jetson Nano B01 and is based on the Nvidia Jetson Nano SOM onboard with 16GB eMMC (fan cooling).

I found a tutorial on how to boot from the SD card (Firmware update | youyeetoo wiki), but it is not entirely clear to me. I think that the system was booting from the eMMC, and the SD card was just acting as media storage. I am currently installing Ubuntu on an old spare computer, so I have not tried the tutorial yet. My question is, should I follow this tutorial, and is it up to date?

Furthermore, I am facing an issue where Python libraries are only downloading in the booting disk, and I would like to resolve this problem. Can you please suggest any other solutions to get my Jetson Nano Developers Kit booting again, and how I can fix my space issue with Python libraries?

Thank you for your help.

You can refresh the SDK through SDKManager, and you should be able to restart. I suggest you use the SD card in the tutorial to start. After using the SD card to start, the SD card is equivalent to the system disk and will have a complete 128G memory. Then you can follow the Change the download path according to your needs.
The wiki’s tutorials are up to date. Please follow the tutorial.