Problem on Bulding Android Image


When I try to build the Android source code based on Display output=EDP & Wifi config,
During the build process, a question showed up asking about the PMUIO2 supply power voltage.
Although I tried to select an option(I have tried both cases) it asked the same question again and again and after many times build process finished unsuccessfully.
I downloaded and used the provided Ubuntu Image on Youyeetoo Google Drive.

Could you please help me how I can fix this problem?

Note that during the compilation process, if a window selection appears, select 18 for VCCIO4 and VCCIO6, and 33 for others.If you still get an error, please contact us

Thank you for your support.

1- Which one of these has been used on the RK3568 development board? I have purchased RK3568 development board and have no Idea about it power supply design.Is there any document that describes about VCCIO4 or VCCIO6 or others?

2-How I can select 18 or 33 ? is there any short-key defined?As far as I can remember I used Tab key to select an option and to verify using but for both of options it will fails.

Use the up and down arrow keys to select, and use the Enter key to confirm.Take the picture you posted as an example.
Any questions please contact us

Thank you for your support.
How can I understand what is the appropriate choice for PMUIO2, VCCIO3,VCCIO4,5,6,7, etc… supply power voltage?

This is the my output:

VCCIO4 Supply Power Voltage has changed!!! please reconfirm!!!
VCCIO6 Supply Power Voltage has changed!!! please reconfirm!!!
io-domian  default as:
		    	&pmu_io_domains {
				status = okay;
				pmuio1-supply = <&vcc3v3_pmu>;
				pmuio2-supply = <&vcc3v3_pmu>;
				vccio1-supply = <&vccio_acodec>;
				vccio3-supply = <&vccio_sd>;
				vccio4-supply = <&vcc_3v3>;
				vccio5-supply = <&vcc_3v3>;
				vccio6-supply = <&vcc_3v3>;
				vccio7-supply = <&vcc_3v3>;
			Need to be modified according to the actual hardware
			for example rk3568-evb:
			&pmu_io_domains {
				status = okay;
				pmuio1-supply = <&vcc3v3_pmu>;
				pmuio2-supply = <&vcc3v3_pmu>;
				vccio1-supply = <&vccio_acodec>;
				vccio3-supply = <&vccio_sd>;
				vccio4-supply = <&vcc_1v8>;
				vccio5-supply = <&vcc_3v3>;
				vccio6-supply = <&vcc_1v8>;
				vccio7-supply = <&vcc_3v3>;

		io-domain docs:

		Android11 SDK:
		RKDocs/android/Rockchip_Developer_Guide_Android11_SDK_V1.1.2_CN.pdf or newer.

		RK356X Linux SDK:

arch/arm64/Makefile:203: recipe for target 'rk3568-evb1-ddr4-v10.img' failed
make: *** [rk3568-evb1-ddr4-v10.img] Error 1

it failed even when I chose the default value! ( I choose 3v3 for all parameters).
Could you please help me with the parameters of pmuio1-supply, pmuio2-supply, vccio1-supply, vccio3-supply, vccio4-supply, vccio5-supply, vccio6-supply, vccio7-supply.

It was solved using rk3568-evb configuration as a reference.
Thank you for your support.

1 Like

After correcting the voltage issue, I received the below error during the build process.
Dear @haolei123, do you have any advice on how I can fix it?

01:01:47 ************************************************************
01:01:47 You are building on a machine with 3.84GB of RAM
01:01:47 The minimum required amount of free memory is around 16GB,
01:01:47 and even with that, some configurations may not work.
01:01:47 If you run into segfaults or other errors, try reducing your
01:01:47 -j value.
01:01:47 ************************************************************
[100% 189/189] out/soong/.bootstrap/bin/soong_build out/soong/
FAILED: out/soong/
out/soong/.bootstrap/bin/soong_build -t -l out/.module_paths/Android.bp.list -b out/soong -n out -d out/soong/ -globFile out/soong/.bootstrap/ -o out/soong/ Android.bp
libRkTeeWeaver want to conditional Compile
libcameradevice want to conditional Compile
libgralloc_priv want to conditional Compile
librga want to conditional Compile
librockit want to conditional Compile
Rockchip conditional compile
Optee Version: v2
[hardware/rockchip/libgralloc/bifrost frameworks/native/include system/core/libsync system/core/libsync/include external/libdrm/include/drm] 30
>>>>>>>>>>>>>>>>>>>>> rk356x
libcameradevice curr board is rk356x
01:21:21 soong bootstrap failed with: exit status 1
ninja: build stopped: subcommand failed.

#### failed to build some targets (19:38 (mm:ss)) ####

Build android failed!

The ram of your machine is too small. Compiling the Android source code requires at least 16GB of ram. If you don’t want to change your memory stick, you can try to maximize your swap memory, but if you do this, the compilation will be very slow and may not be effective. So I still recommend you to increase your ram.

If you have any questions please contact me

Dear @haolei123 ,
Thank you for your support.
I added 16GB of swap memory, which solved that problem but I have received another error during the build process.
Could you please help me about the reason of this new problem?

external/rkaiq_tool_server/rkaiq/rkaiq_protocol.cpp:561:64: warning: format specifies type 'unsigned int' but the argument has type 'unsigned long long' [-Wformat]
    LOG_DEBUG("FILETRANS receive: receivedData.dataSize:%u\n", receivedData.dataSize);
                                                        ~~     ^~~~~~~~~~~~~~~~~~~~~
external/rkaiq_tool_server/logger/log.h:55:70: note: expanded from macro 'LOG_DEBUG'
            ALOGD("%s:%d - " format "", __BI_FILENAME__, __LINE__, ##__VA_ARGS__);                                     \
                             ~~~~~~                                  ^~~~~~~~~~~
system/core/liblog/include_vndk/log/log_main.h:227:52: note: expanded from macro 'ALOGD'
#define ALOGD(...) ((void)ALOG(LOG_DEBUG, LOG_TAG, __VA_ARGS__))
system/core/liblog/include_vndk/log/log_main.h:336:67: note: expanded from macro 'ALOG'
#define ALOG(priority, tag, ...) LOG_PRI(ANDROID_##priority, tag, __VA_ARGS__)
system/core/liblog/include_vndk/log/log_main.h:94:69: note: expanded from macro 'LOG_PRI'
#define LOG_PRI(priority, tag, ...) android_printLog(priority, tag, __VA_ARGS__)
system/core/liblog/include_vndk/log/log_main.h:85:34: note: expanded from macro 'android_printLog'
  __android_log_print(prio, tag, __VA_ARGS__)
external/rkaiq_tool_server/rkaiq/rkaiq_protocol.cpp:55:13: warning: unused function 'HexDump' [-Wunused-function]
static void HexDump(const unsigned char* data, size_t size)
6 warnings generated.
[ 43% 45873/105675] //external/rkaiq_tool_server:rkaiq_tool_server clang++ rkaiq/rkaiq_raw_protocol.cpp
external/rkaiq_tool_server/rkaiq/rkaiq_raw_protocol.cpp:445:42: warning: comparison of integers of different signs: 'uint32_t' (aka 'unsigned int') and '__s32' (aka 'int') [-Wsign-compare]
            if (CapParam->focus_position > focus_query.maximum)
                ~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~~~~~~
external/rkaiq_tool_server/rkaiq/rkaiq_raw_protocol.cpp:447:42: warning: comparison of integers of different signs: 'uint32_t' (aka 'unsigned int') and '__s32' (aka 'int') [-Wsign-compare]
            if (CapParam->focus_position < focus_query.minimum)
                ~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~~~~~~
2 warnings generated.
[ 45% 47774/105675] //external/dtc:dtc gen yacc [linux_glibc]
external/dtc/dtc-parser.y: warning: 3 shift/reduce conflicts [-Wconflicts-sr]
[ 45% 47820/105675] //hardware/rockchip/libmpimmz:gen_mmz_version generate version.h
fatal: not a git repository (or any of the parent directories): .git
[ 45% 47824/105675] //external/guice:guice_munge_srcjar generate guice_munge.srcjar
18:38:31 ninja failed with: exit status 137

#### failed to build some targets (02:59:51 (hh:mm:ss)) ####

Build android failed!

I understand your situation now. It should be that the source code has not been updated. I will update the source code later and notify you as soon as it is completed.

Thank you @haolei123.
I’m eagerly looking forward.

Is there any update on the source code?

Sorry for the long wait, the source code has been updated on Google Cloud Drive. Please contact me if you have any questions.

1 Like

Dear @haolei123 thank you for your following up.
After download and decompression of new image files , unlike the previous archive just docker build is present in the archive.(1.5BG).
Could you please check it out?

You can use docker to compile, or you can use the .git warehouse to compile. .git is a hidden file.