New LinkPi ENC1 (EX2) does not boot after firmware upgrade and restore rootfs method does not work

To whom it may concern:

I just purchased a brand new LinkPi ENC1 (EX2) encoder and attempted to update the firmware through the web interface using the suggested .bin firmware file.

Now, the unit does not boot at all, and all of my attempts to restore using the rootfs method do not seem to be working as there is no change from the boot LinkPi logo on the OLED screen or through the HDMI video signal, i.e. no “updating” status message even after several minutes.

In summary, I followed the instructions outlined here:

And I tried several rootfs bundles for the ENC1 (EX2), including but not limited to:





Furthermore, I tried various different methods of partitioning the thumb drive in both Windows and Linux.

Each time, I verified that there is only one primary FAT32 partition, and I even tried both DOS/MBR and GPT partitioning as well as changing the sector size.

For whatever reason, the unit does not seem to be updating, nor is there any indication that the process is even initiating properly let alone getting far enough along that it is obvious the process has started.

So I am requesting assistance or guidance.


P.S. The reason why I decided to try updating the firmware in the first place was because the bottom few rows of pixels the video were flashing green.

A very likely reason for this is that the flash drive is not thoroughly formatted.

Please try to use diskgenius or SDFormatter to remove the hidden partitions and reformat to FAT32.

Hello! Your answer is here:

Follow the directions above. If it doesn’t work, its your USB stick. Try a different stick and eventually one will work. Best chances are with the oldest smallest USB stick you can find. I had trouble and got past it with an old 2GB drive. Just format it and try it (again), and when one works, save it because it will come in handy.

1 Like