Issue with YYT MIPI7LCD and X1 SBC- Split display shows twice the same screen


I cannot get the MIPI7LCD to work properly with the X1. I updated the BIOS and installed the driver as mentioned in the wiki. However the display is split in half horizontally and shows twice the same thing. Please se picture.

Thank you for your help

Can you try if it works under linux?

If it still doesn’t work, try replacing the connection cable.

Thank you for your response. However I really need to use w\Windows. One thing that comes to mind is that I may have used the wrong BIOS file. Could you please send me the link to the correct BIOS file for Windows. I cannot find the bin files that end in 1.8V.bin or 3.3V.bin from this link: enter BIOS | youyeetoo wiki

The only bin files that I am able to download from the link above are these ones:

Thank you again for your help

I updated the wiki and uploaded the BIOS to Google Drive.

Thank you. I purchased a new screen. This one works except that the touchscreen doesn’t. It is not responsive regardless of where or how I tap the screen.
Does anyone know how I can enable touch screen on a YYT MIPI7LCD,

Thank you

From the feedback of the test bloggers, it just needs a bios update.

I tried both the 1.8v and the 3v BIOS file and neither worked. It looks like the touchscreen function only works on Linux based OS.

Does it work in linux?

Yes it works in Linux but not with Windows

Have you installed all the drivers for windows, if not, please install them completely.