Install ubuntu via SD card

On the page the program is not downloaded in the SD_Firmware_Tool section. I found Rockchip Create Upgrade Disk Tool 1.53 on the Internet, but when I click the “create” button, it says “opening firmware fails!” for any image. What to do?

Hello Please try the link below, thanks.

Thanks. Now the program does not see the sd card. SD card - sdhc format, fat32 file system.

Can’t recognize SD card after you burn or software can’t recognize your SD card directly?
Share some photos.
If your card is recognized by your computer, try running the software through an administrator.

Software can’t recognize your SD card directly. I was running the software through an administrator.

If it helps you, then version 1.53 sees the SD card, but complains about the image (.img file). When you click on the “create” button, it gives an error.

please share your v1.53 and show your error.

I think it may be a system language problem. You can try under the virtual machine or switch the system language to English. My test environment is win10 Chinese.

Try modifying config.ini to 2 or modify the language of the computer system.



It didn’t help, besides it works in version 1.53

Have you tried other SD cards?

I have exactly the same error. Tried a few different sd cards.

Whats the issue?

Alternatively, can someone advise how to change the android system to ubuntu?

There are two ways:

  1. Update via Type-C
  2. Update via SD card.

Здравствуйте. Мне удалось записать образ ROC-RK3588S-PC_Ubuntu20.04-Gnome-r211123_v1.0.2a_221013 на sd. Далее я подал питание на плату с вставленной SD картой. На экране монитора ничего не появлялось, но лампочка питания мигала в два цвета: синий и розовый. Я подождал минут 5 - 10, ничего на мониторе не появилось, а лампочка стала гореть только розовым цветом. Я отключил питание и извлек SD карту. Компьютер теперь вообще ничего не запускает. Что делать?

Hello. I managed to burn an image of ROC-RK3588S-PC_Ubuntu20.04-Gnome-r211123_v1.0.2a_221013 to sd. Next, I applied power to the board with the inserted SD card. Nothing appeared on the monitor screen, but the power light was flashing in two colors: blue and pink. I waited for 5-10 minutes, nothing appeared on the monitor, and the light bulb began to burn only pink. I turned off the power and removed the SD card. The computer now doesn’t run anything at all. What to do?

Please try this and give us more detail.

somethisn output via debug uart?
have you format your SD by diskgenius ?if not ,please try.

So let’s take it in order:

  1. Now I need to upload an image to the SD card (a large file with the .img extension) and tick SD boot, not Upgrade firmware, as it was in the instructions?
  2. Next, I just insert the SD card and supply power, or do I still need to clamp the “recovery” button?

Yes, you only need to select SD BOOOT and burn the ubuntu image to the SD card. The system will only run on the SD card and will not update the EMMC system.
Yes, after burning successfully, you only need to insert the SD card and turn on the power.

Did as you said. The SD card was split into many parts 7-8 (SD - 64 GB volume). I inserted it into the RK3588S-PC, nothing was displayed on the screen. Just a black screen. Now without SD, too, only a black screen. What to do?

Please provide the debug log file you started via SD.